什么情况下该升级xcode编译器?


升级编译器有时候是件痛苦的事情,一方面可能公司网速渣,另一方面,升级后的编译器往往会有很多新的问题出现,比如编译器bug或者底层框架废弃了某个文件,而你正在使用的第三方库可能尚未及时更新(ps:这周我遇到高德地图出现这种情况)。

当然,如果说以上都是借口,那么还归结为一个字,懒;但懒归懒,必须得清楚什么时候可以懒一下,什么时候必须升级;这就是我要说的。

什么时候可以懒

如果,仅仅为了支持在最新的系统上进行(真机)调试,这时候,可以不升级xcode,按照下面的描述操作,就可以让你现在正在使用的xcode支持在最新系统上调试。

找一个已经升级xcode的开发小伙伴(没有的话,可以去各大QQ群问一下),把/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport目录下的最新系统支持文件拷本一个副本到你的相应目录下即可。

什么时候必须升级

假如你要在正在开发的项目中,采用或者调试新系统最新特性或新API。这种情况下,就必须得升级xcode了,因为使用新特性或者新的API,需要最新的SDK来编译,而只有最新的xcode有最新的SDK。

参考:https://stackoverflow.com/questions/37945376/use-xcode-7-with-ios-10

知识共享许可协议本作品采用知识共享署名-非商业性使用 4.0 国际许可协议进行许可。
本站文章除注明转载/出处外,均为本站原创或翻译,请务必在遵守许可协议的前提下转载。
发布时间:2018-10-16 15:46:01 阅读:935 标签:技术日常备注